PTA甲级 1090 Highest Price in Supply Chain (C++)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P P P and sell or distribute them in a price that is r r r% higher than P P P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N ( ≤ 1 0 5 ) N (≤10^5) N(105), the total number of the members in the supply chain (and hence they are numbered from 0 to N − 1 N−1 N1); P P P, the price given by the root supplier; and r r r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S i S_i Si is the index of the supplier for the i i i-th member. S r o o t S_{root} Sroot for the root supplier is defined to be − 1 −1 1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1 0 10 10^{10} 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-24 11:35:47
// All rights reserved.

#include <iostream>
#include <vector>
#include <queue>
#include <cmath>

using namespace std;

int main(){
    int n;
    double p, r;

    cin >> n >> p >> r;
    vector<vector<int>> net(n);
    int root;
    int num = 0, ansLevel = 0;

    for(int i = 0; i < n; ++i) net[i].push_back(i);
    for(int i = 0; i < n; ++i){
        int tmp;
        scanf("%d", &tmp);
        if(tmp == -1) root = i;
        else net[tmp].push_back(i);
    }

    queue<int> q;
    q.push(root);
    int level = 0;

    while(true){
        int size = q.size();

        for(int i = 0; i < size; ++i){
            int tmp = q.front();
            q.pop();

            if(net[tmp].size() == 1){
                if(ansLevel == level) num++;
                else{
                    ansLevel = level;
                    num = 1;
                }
            }
            else{
                for(int j = 1; j < net[tmp].size(); ++j) q.push(net[tmp][j]);
            }
        }
        level++;
        if(q.empty()) break;
    }

    printf("%.2lf %d\n", p * pow(1 + r / 100, ansLevel), num);

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值