PTA甲级 1110 Complete Binary Tree (C++)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 20 ) N (≤20) N(20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N − 1 N−1 N1. Then N N N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 2

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-24 23:04:09
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>
#include <queue>

using namespace std;

vector<pair<int, int>> input;

struct Node{
    int key;
    int levelOrder;
    Node *left;
    Node *right;

    Node(int k = -1){
        key = k;
        levelOrder = -1;
        left = NULL;
        right = NULL;
    }
    ~Node(){}
};

void findChildren(Node *r){
    if(r -> key == -1) return;

    r -> left = new Node(input[r -> key].first);
    r -> right = new Node(input[r -> key].second);

    findChildren(r -> left);
    findChildren(r -> right);
}

int main(){
    int n;

    scanf("%d", &n);

    input.clear();

    unordered_map<int, int> flag;

    for(int i = 0; i < n; ++i){
        string a, b;
        cin >>  a >> b;

        int left, right;
        if(a == "-") left = -1;
        else left = stoi(a);

        if(b == "-") right = -1;
        else right = stoi(b);

        input.emplace_back(left, right);
        flag[left] = flag[right] = 1;
    }

    int r;
    for(int i = 0; i < n; ++i){
        if(flag[i] != 1){
            r = i;
            break;
        }
    }

    Node *root = new Node(r);
    findChildren(root);

    queue<Node*> q;
    q.push(root);    
    int lastNode = root -> key;
    int cnt = 0;
    bool isCBT = true;

    while(true){
        if(q.front() -> key == -1){
            if(cnt != n) isCBT = false;
            break;
        }
        else{
            lastNode = q.front() -> key;
            q.push(q.front() -> left);
            q.push(q.front() -> right);

            cnt++;
            q.pop();
        }
    }

    if(isCBT == false) printf("NO %d\n", root -> key);
    else printf("YES %d\n", lastNode);

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值