PTA甲级 1064 Complete Binary Search Tree (C++)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 1000 ) N (≤1000) N(1000). Then N N N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-19 22:32:07
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>

using namespace std;


struct Node{
    int ID;
    int key;
    Node* left;
    Node* right;

    Node(int id = -1, Node* l = NULL, Node* r = NULL){
        ID = id;
        left = l;
        right = r;
    }

    ~Node(){}
};

int n;
vector<Node*> midOrder;
vector<int> nums;

void developTree(Node *r){
    if(r -> ID * 2 <= n){
        if(r -> ID * 2 == n) r -> left = new Node(n, NULL, NULL);
        else{
            r -> left = new Node(r -> ID * 2, NULL, NULL);
            r -> right = new Node(r -> ID * 2 + 1, NULL, NULL);

            developTree(r -> left);
            developTree(r -> right);
        }
    }

}

void midTraverse(Node *r){
    if(r -> left != NULL) midTraverse(r -> left);
    midOrder.push_back(r);
    if(r -> right != NULL) midTraverse(r -> right);

    return;
}

int main(){
    
    cin >> n;

    nums.resize(n);

    for(int i = 0; i < n; ++i) scanf("%d", &nums[i]);
    sort(nums.begin(), nums.end());

    // 现在这个数组是二叉树的中序遍历
    Node* root = new Node(1, NULL, NULL);
    developTree(root);
    
    midOrder.clear();
    midTraverse(root);
    
    for(int i = 0; i < midOrder.size(); ++i) midOrder[i] -> key = nums[i];

    queue<Node*> q;

    q.push(root);
    while(!q.empty()){
        if(q.front() -> left != NULL) q.push(q.front() -> left);
        if(q.front() -> right != NULL) q.push(q.front() -> right);

        Node *tmp = q.front();
        q.pop();
        if(q.empty()) printf("%d\n", tmp -> key);
        else printf("%d ", tmp -> key);
    }


    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值