PTA甲级 1109 Group Photo (C++)

这篇博客介绍了一种将人群按照特定规则排列的方法,包括按身高和姓名字母顺序排列,并按矩阵形式输出。给定总人数N和行数K,程序会将人们分成K行,每行人数尽可能均匀,高个子居中,矮个子在两侧。代码实现了输入人员信息并输出排列后的矩阵布局。
摘要由CSDN通过智能技术生成

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N / K N/K N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  • All the people in the rear row must be no shorter than anyone standing in the front rows;
  • In each row, the tallest one stands at the central position (which is defined to be the position ( m / 2 + 1 ) (m/2+1) (m/2+1), where m m m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N ( ≤ 1 0 4 ) N (≤10^4) N(104), the total number of people, and K ( ≤ 10 ) K (≤10) K(10), the total number of rows. Then N N N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation – that is, print the names of people in K K K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-25 18:07:13
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

struct People{
    string name;
    int height;

    People(string n, int h){
        name = n;
        height = h;
    }

    ~People(){}
};

bool cmp(People &a, People &b){
    if(a.height != b.height) return a.height < b.height;
    else return a.name > b.name;
}

int main(){
    int n, k;
    scanf("%d %d", &n, &k);

    vector<People> people;
    string name;
    int height;

    for(int i = 0; i < n; ++i){
        cin >> name >> height;
        people.emplace_back(name, height);
    }

    sort(people.begin(), people.end(), cmp);

    int col = n / k;
    vector<vector<string>> formation(k);

    for(int i = 0; i < k; ++i){
        int minPos = (k - 1 - i) * col;

        int maxPos;
        if(i == 0) maxPos = n - 1;
        else maxPos = (k - i) * col - 1;

        if((maxPos - minPos + 1) % 2 == 0){
            int peoplePos = minPos;

            for(int j = 0; j < (maxPos - minPos + 1) / 2; ++j){
                formation[i].push_back(people[peoplePos].name);
                peoplePos += 2;
            }

            peoplePos = maxPos;

            for(int j = 0; j < (maxPos - minPos + 1) / 2; ++j){
                formation[i].push_back(people[peoplePos].name);
                peoplePos -= 2;
            }
        }
        else{
            int peoplePos = minPos + 1;

            for(int j = 0; j < (maxPos - minPos + 1) / 2; ++j){
                formation[i].push_back(people[peoplePos].name);
                peoplePos += 2;
            }

            formation[i].push_back(people[maxPos].name);
            peoplePos = maxPos - 2;

            for(int j = 0; j < (maxPos - minPos + 1) / 2; ++j){
                formation[i].push_back(people[peoplePos].name);
                peoplePos -= 2;
            }
        }
    }


    for(int i = 0; i < formation.size(); ++i){
        for(int j = 0; j < formation[i].size(); ++j){
            if(j == formation[i].size() - 1) printf("%s\n", formation[i][j].c_str());
            else printf("%s ", formation[i][j].c_str());
        }
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值