PTA甲级 1116 Come on! Let‘s C (C++)

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
  • 1、 Those who ranked as a prime number will receive the best award – the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1 0 4 ) N (≤10^4) N(104), the total number of contestants. Then N N N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K K K followed by K K K query ID’s.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-26 11:51:20
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>
#include <cmath>

using namespace std;

bool isPrime(int n){
    if(n == 1) return false;
    if(n <= 3) return true;

    for(int i = 2; i <= sqrt(n); ++i){
        if(n % i == 0) return false;
    }

    return true;
}

int main(){
    int n;
    cin >> n;

    unordered_map<string, int> ranklist, hasAsked;

    string id;
    for(int i = 0; i < n; ++i){
        cin >> id;
        ranklist[id] = i + 1;
    }

    int k;
    cin >> k;
    for(int i = 0; i < k; ++i){
        cin >> id;

        if(ranklist[id] != 0 && hasAsked[id] == 1) printf("%s: Checked\n", id.c_str());
        else if(ranklist[id] != 0 && hasAsked[id] == 0){
            string award;

            if(ranklist[id] == 1) award = "Mystery Award";
            else if(isPrime(ranklist[id])) award = "Minion";
            else award = "Chocolate";

            printf("%s: %s\n", id.c_str(), award.c_str());
            hasAsked[id] = 1;
        }

        else printf("%s: Are you kidding?\n", id.c_str());
    }


    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值