1116 Come on! Let's C(20 分)

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

思路:

给出N个学生的排名,输出他们每个人的奖品,排名是质数的奖品小黄人,每个人都有巧克力。若查询人不在排名里,则输出“Are you kidding?”,查询过的输出“Checked”

C++:

#include "iostream"
#include "map"
#include "string"
#include "cmath"
using namespace std;
bool visit[10010];
map<int,string> appli;
int accord[10010];
bool isprime(int a) {
	if(a <= 1) return false;
	int Sqrt = sqrt((double)a);
	for(int i = 2; i <= Sqrt; i++) {
		if(a % i == 0)
			return false;
	}
	return true;
}
int main(){
	int n;
	scanf("%d",&n);
	for (int i=0;i<n;i++)
	{
		int temp;
		scanf("%d",&temp);
		accord[temp]=1;
		if (i==0)		//第一名
			appli[temp]="Mystery Award";
		else if (isprime(i+1))	//质数排名
			appli[temp]="Minion";
		else
			appli[temp]="Chocolate";
	}
	scanf("%d",&n);
	for (int i=0;i<n;i++)
	{
		int temp;
		scanf("%d",&temp);
		if (visit[temp]==true)//查看过
		{
			printf("%04d: Checked\n",temp);
		}else if(visit[temp]==false&&accord[temp]==1)
		{
			printf("%04d: ",temp);
			auto it=appli.find(temp);
			cout<<(*it).second<<endl;
			visit[temp]=true;
		}else if(accord[temp]!=1)
		{
			printf("%04d: Are you kidding?\n",temp);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值