PTA甲级 1121 Damn Single (C++)

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 50 , 000 ) N (≤ 50,000) N(50,000), the total number of couples. Then N N N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M ( ≤ 10 , 000 ) M (≤ 10,000) M(10,000) followed by M M M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-27 10:49:20
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>

using namespace std;

int main(){
    int n;
    scanf("%d", &n);

    unordered_map<string, string> couples;
    for(int i = 0; i < n; ++i){
        string a, b;
        cin >> a >> b;

        couples[a] = b;
        couples[b] = a;
    }

    unordered_map<string, bool> isIn;
    vector<string> ans;
    int m;
    scanf("%d", &m);
    for(int i = 0; i < m; ++i){
        string tmp;
        cin >> tmp;
        if(couples[tmp] == "") ans.push_back(tmp);

        else{
            if(isIn[couples[tmp]] == false){
                ans.push_back(tmp);
                isIn[tmp] = true;
            }

            else ans.erase(find(ans.begin(), ans.end(), couples[tmp]));
        }
    }

    sort(ans.begin(), ans.end());
    printf("%d\n", ans.size());
    for(int i = 0; i < ans.size(); ++i){
        if(i == ans.size() - 1) printf("%s\n", ans[i].c_str());
        else printf("%s ", ans[i].c_str());
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值