PTA甲级 1124 Raffle for Weibo Followers (C++)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N N N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M ( ≤ 1000 ) M (≤ 1000) M(1000), N N N and S S S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M M M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-27 17:15:37
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main(){
    int m, n, s;
    scanf("%d %d %d", &m, &n, &s);
    // m - the total number of forwards
    // n - the skip number of winners
    // s - the index of the first winner (the indices start from 1)

    if(s > m){
        printf("Keep going...\n");
        return 0;
    }

    unordered_map<string, bool> hasWon;
    int lastWon = -1;
    
    for(int i = 1; i <= m; ++i){
        string id;
        cin >> id;

        if(lastWon == -1 && i == s){
            printf("%s\n", id.c_str());

            hasWon[id] = true;
            lastWon = i;
            continue;
        }

        if(lastWon != -1 && lastWon + n == i){
            if(hasWon[id]) lastWon++;
            else{
                printf("%s\n", id.c_str());

                hasWon[id] = true;
                lastWon = i;
            }
        }
    }


    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值