PTA甲级 1143 Lowest Common Ancestor (C++)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M ( ≤ 1 , 000 ) M (≤ 1,000) M(1,000), the number of pairs of nodes to be tested; and N ( ≤ 10 , 000 ) N (≤ 10,000) N(10,000), the number of keys in the BST, respectively. In the second line, N N N distinct integers are given as the preorder traversal sequence of the BST. Then M M M lines follow, each contains a pair of integer keys U U U and V V V. All the keys are in the range of int.

Output Specification:

For each given pair of U U U and V V V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U U U and V V V, print X is an ancestor of Y. where X is A and Y is the other node. If U U U or V V V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

Caution:

发现一些二叉搜索树的问题如果知道了前序遍历其实没必要建树,可以省下很多时间。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-29 22:47:46
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>

using namespace std;

int main(){
    int m, n;
    scanf("%d %d", &m, &n);

    vector<int> preOrder(n);
    unordered_map<int, bool> isInTree;

    for(int i = 0; i < n; ++i){
        scanf("%d", &preOrder[i]);
        isInTree[preOrder[i]] = true;
    }

    for(int i = 0; i < m; ++i){
        int id1, id2;
        scanf("%d %d", &id1, &id2);

        if(isInTree[id1] == false && isInTree[id2] == true) printf("ERROR: %d is not found.\n", id1);
        else if(isInTree[id1] == true && isInTree[id2] == false) printf("ERROR: %d is not found.\n", id2);
        else if(isInTree[id1] == false && isInTree[id2] == false) printf("ERROR: %d and %d are not found.\n", id1, id2);
        else{
            int pos = 0;
            int less = min(id1, id2);
            int bigger = max(id1, id2);

            while(true){
                if(less < preOrder[pos] && bigger > preOrder[pos]){
                    printf("LCA of %d and %d is %d.\n", id1, id2, preOrder[pos]);
                    break;
                }

                else if(less == preOrder[pos]){
                    printf("%d is an ancestor of %d.\n", less, bigger);
                    break;
                }

                else if(bigger == preOrder[pos]){
                    printf("%d is an ancestor of %d.\n", bigger, less);
                    break;
                }

                else if(bigger < preOrder[pos]){
                    pos++;
                }
                else if(less > preOrder[pos]){
                    pos = lower_bound(preOrder.begin() + pos + 1, preOrder.end(), preOrder[pos]) - preOrder.begin();
                }
            }
        }
    }
    
    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值