PTA甲级 1144 The Missing Number (C++)

本文介绍了解决LeetCode问题中如何找到给定整数列表中缺失的最小正整数。通过输入样例10和5-25961342517,展示了如何使用C++代码实现并查找缺失的数字7。涉及的数据结构、查找算法和代码优化技巧。
摘要由CSDN通过智能技术生成

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1 0 5 ) N (≤10^5) N(105). Then N N N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

Caution:

leetcode原题

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-30 10:40:30
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int main(){
    int n;
    scanf("%d", &n);

    vector<int> nums(n + 1);
    vector<bool> flags(n + 1, false);
    for(int i = 0; i < n; ++i){
        int tmp;
        scanf("%d", &tmp);

        if(tmp <= n && tmp >= 1 && flags[tmp] == true) tmp = -1;
        else if(tmp <= n && tmp >= 1 && flags[tmp] == false) flags[tmp] = true;

        nums[i + 1] = tmp;
    }

    for(int i = 1; i <= n; ++i){
        while(nums[i] <= n && nums[i] >= 1 && nums[i] != i) swap(nums[i], nums[nums[i]]);
    }

    for(int i = 1; i <= n; ++i){
        if(nums[i] != i){
            printf("%d\n", i);
            return 0;
        }
    }

    printf("%d\n", n + 1);

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值