1144. The Missing Number (20)

1144. The Missing Number (20)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7


给一串数字,找出没有给出的最小正整数。给了N<=100000,那么答案就在这里面。比较简单


#include <cstdio>

using namespace std;

int N;
int sz[100010];

int main() {
	scanf("%d\n", &N);
	int t;
	for (int i = 0; i < N; i++) {
		scanf("%d", &t);
		if (t > 0 && t<100010) {
			sz[t] = 1;
		}
	}
	for (int i = 1; i < 100010; i++) {
		if (sz[i] == 0) {
			printf("%d", i);
			break;
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值