1144. The Missing Number (20)
时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.
Output Specification:
Print in a line the smallest positive integer that is missing from the input list.
Sample Input:10 5 -25 9 6 1 3 4 2 5 17Sample Output:
7
给一串数字,找出没有给出的最小正整数。给了N<=100000,那么答案就在这里面。比较简单
#include <cstdio>
using namespace std;
int N;
int sz[100010];
int main() {
scanf("%d\n", &N);
int t;
for (int i = 0; i < N; i++) {
scanf("%d", &t);
if (t > 0 && t<100010) {
sz[t] = 1;
}
}
for (int i = 1; i < 100010; i++) {
if (sz[i] == 0) {
printf("%d", i);
break;
}
}
return 0;
}