PTA甲级 1076 Forwards on Weibo (C++)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L L L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N ( ≤ 1000 ) N (≤1000) N(1000), the number of users; and L ( ≤ 6 ) L (≤6) L(6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N N N. Then N N N lines follow, each in the format:

M[i] user_list[i]

where M[i] ( ≤ 100 ≤100 100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K K K is given, followed by K K K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L L L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-02 15:50:11
// All rights reserved.

#include <iostream>
#include <vector>
#include <queue>
#include <unordered_map>

using namespace std;

int main(){
    int n, l;
    scanf("%d %d", &n, &l);
    vector<vector<int>> follows;
    follows.resize(n + 1);

    for(int i = 0; i < n; ++i){
        int num;
        scanf("%d", &num);

        for(int j = 0; j < num; ++j){
            int tmp;
            scanf("%d", &tmp);
            follows[tmp].push_back(i + 1);
        }
    }

    int k;
    scanf("%d", &k);
    for(int i = 0; i < k; ++i){
        int query;
        scanf("%d", &query);

        int level = -1;
        int cnt = -1;
        unordered_map<int, bool> visited;
        visited[query] = true;

        queue<int> q;
        q.push(query);
        while(true){
            int size = q.size();
            cnt += size;

            for(int i = 0; i < size; ++i){
                int tmp = q.front();
                q.pop();
                
                for(int j = 0; j < follows[tmp].size(); ++j){
                    if(visited[follows[tmp][j]] == true) continue;
                    visited[follows[tmp][j]] = true;
                    q.push(follows[tmp][j]);
                }
            }

            if(++level == l || q.empty()) break;
        }
        printf("%d\n", cnt);
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值