浙江大学计算机与软件学院 2019 年保研机考 7-3 Is It An AVL Tree (C++)

In computer science, an AVL tree (Georgy Adelson-Velsky and Evgenii Landis’ tree, named after the inventors) is a self-balancing binary search tree. It was the first such data structure to be invented. In an AVL tree, the heights of the two child subtrees of any node differ by at most one. (Quoted from wikipedia)

For each given binary search tree, you are supposed to tell if it is an AVL tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K ( ≤ 10 ) K (≤10) K(10) which is the total number of cases. For each case, the first line gives a positive integer N ( ≤ 30 ) N (≤30) N(30), the total number of nodes in the binary search tree. The second line gives the preorder traversal sequence of the tree with all the keys being distinct. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in a line “Yes” if the given tree is an AVL tree, or “No” if not.

Sample Input:

3
7
50 40 36 48 46 62 77
8
50 40 36 48 46 62 77 88
6
50 40 36 48 46 62

Sample Output:

Yes
No
No

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-19 19:16:14
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

struct Node{
    int key;
    Node *left;
    Node *right;

    Node(int k){
        key = k;
        left = NULL;
        right = NULL;
    }
    ~Node(){}
};

Node *root;

void insert(Node *r, int k){
    if(r == NULL) r = new Node(k);

    if(k < r -> key){
        if(r -> left == NULL) r -> left = new Node(k);
        else insert(r -> left, k);
    }

    else{
        if(r -> right == NULL) r -> right = new Node(k);
        else insert(r -> right, k);
    }
}

int getHeight(Node *r){
    if(r == NULL) return 0;
    return max(getHeight(r -> left), getHeight(r -> right)) + 1;
}

bool isAVL(Node *r){
    if(r == NULL) return true;

    int leftHeight = getHeight(r -> left);
    int rightHeight = getHeight(r -> right);

    if(leftHeight - rightHeight >= -1 && leftHeight - rightHeight <= 1) return isAVL(r -> left) && isAVL(r -> right);
    else return false;
}

int main(){
    int k;
    scanf("%d", &k);

    int n;
    for(int i = 0; i < k; ++i){
        scanf("%d", &n);
        
        int tmp;
        for(int j = 0; j < n; ++j){
            scanf("%d", &tmp);

            if(j == 0) root = new Node(tmp);
            else insert(root, tmp);
        }

        if(isAVL(root)) printf("Yes\n");
        else printf("No\n");
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值