A Simple Problem with Integers 线段树

POJ 3468

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds
of operations. One type of operation is to add some given number to
each number in a given interval. The other is to ask for the sum of
numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000. The
second line contains N numbers, the initial values of A1, A2, … ,
AN. -1000000000 ≤ Ai ≤ 1000000000. Each of the next Q lines represents
an operation. “C a b c” means adding c to each of Aa, Aa+1, … , Ab.
-10000 ≤ c ≤ 10000. “Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

//MADE BY Y_is_sunshine;
//#include <bits/stdc++.h>
//#include <memory.h>
#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <sstream>
#include <cstdio>
#include <vector>
#include <string>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>

#define INF 0x3f3f3f3f
#define MAXN 100005

using namespace std;

struct node {
	int l, r;
	long long w, mark;
}tree[MAXN*4];

int a, b, cnt = 0;
long long ans, s;

void built(int l1,int r1,int num) {
	tree[num].l = l1;
	tree[num].r = r1;
	if (l1 == r1) {
		scanf("%lld", &tree[num].w);
		return;
	}
	int mid = (l1 + r1) >> 1;
	built(l1, mid, num << 1);
	built(mid + 1, r1, num << 1 | 1);
	tree[num].w = tree[num << 1].w + tree[num << 1 | 1].w;
}

void down(int num) {
	tree[num << 1].mark += tree[num].mark;
	tree[num << 1 | 1].mark += tree[num].mark;
	tree[num << 1].w += tree[num].mark*(tree[num << 1].r - tree[num << 1].l + 1);
	tree[num << 1 | 1].w += tree[num].mark*(tree[num << 1 | 1].r - tree[num << 1 | 1 ].l + 1);
	tree[num].mark = 0;
}

void add_1(int num) {
	if (tree[num].l == tree[num].r)
		tree[num].w += s;
	if (tree[num].mark)
		down(num);
	int mid = (tree[num].l + tree[num].r) >> 1;
	if (num <= mid)
		add_1(num << 1);
	else
		add_1(num << 1 + 1);
	tree[num].w = tree[num << 1].w + tree[num << 1 | 1].w;
}

void add_2(int num) {
	if (tree[num].l >= a && tree[num].r <= b) {
		tree[num].w += (tree[num].r - tree[num].l + 1)*s;
		tree[num].mark += s;
		return;
	}
	if (tree[num].mark)
		down(num);
	int mid = (tree[num].l + tree[num].r) >> 1;
	if (a <= mid)
		add_2(num << 1);
	if (b > mid)
		add_2(num << 1 | 1);
	tree[num].w = tree[num << 1].w + tree[num << 1 | 1].w;
}

void search_1(int num) {
	if (tree[num].l == tree[num].r) {
		ans = tree[num].w;
		return;
	}
	int mid = (tree[num].l + tree[num].r) >> 1;
	if (num <= mid)
		search_1(num << 1);
	else
		search_1(num << 1 + 1);
}

void search_2(int num) {
	if (tree[num].l >= a && tree[num].r <= b) {
		ans += tree[num].w;
		return;
	}
	if (tree[num].mark)
		down(num);
	int mid = (tree[num].l + tree[num].r) / 2;
	if (a <= mid)
		search_2(num << 1);
	if (b > mid)
		search_2(num << 1 | 1);
}

int main()
{
	//freopen("data.txt", "r", stdin);
	
	int N, M;
	while (cin >> N >> M) {
		built(1, N, 1);
		while (M--) {
			char ch;
			scanf(" %c", &ch);
			if (ch == 'Q') {
				ans = 0;
				scanf("%d%d", &a, &b);
				search_2(1);
				printf("%lld\n", ans);
			}
			else {
				scanf("%d%d%lld", &a, &b, &s);
				add_2(1);
			}
		}
	}


	freopen("CON", "r", stdin);
	system("pause");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值