A Simple Problem with Integers (线段树模板)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

题意:两种操作,C:对区间[l,r]每一个数+c.   Q:查询区间[l,r]的和。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define inf 0x3f3f3f3f
#define ll long long
#define N 400010
using namespace std;
ll Sum[N],add[N];
void build(int l,int r,int o)
{
    if(l==r)
    {
        scanf("%lld",&Sum[o]);
        return;
    }
    int mid=(l+r)>>1;
    build(l,mid,o<<1);
    build(mid+1,r,o<<1|1);
    Sum[o]=Sum[o<<1]+Sum[o<<1|1];
}
void pushdown(int o,int l)
{
    if(add[o])
    {
        add[o<<1]+=add[o];
        add[o<<1|1]+=add[o];
        Sum[o<<1]+=add[o]*(l-(l>>1));
        Sum[o<<1|1]+=add[o]*(l>>1);
        add[o]=0;
    }
}
void update(int x,int y,int l,int r,int o,int c)
{
    if(l>=x&&r<=y)
    {
        Sum[o]+=c*(r-l+1);
        add[o]+=c;
        return;
    }
    pushdown(o,r-l+1);
    int mid=(l+r)>>1;
    if(x<=mid)update(x,y,l,mid,o<<1,c);
    if(y>mid)update(x,y,mid+1,r,o<<1|1,c);
    Sum[o]=Sum[o<<1]+Sum[o<<1|1];
}
ll query(int x,int y,int l,int r,int o)
{
    if(l>=x&&r<=y)
        return Sum[o];
    pushdown(o,r-l+1);
    int mid=(l+r)>>1;
    ll sum=0;
    if(x<=mid)sum=query(x,y,l,mid,o<<1);
    if(y>mid)sum+=query(x,y,mid+1,r,o<<1|1);
    return sum;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(Sum,0,sizeof(Sum));
        memset(add,0,sizeof(add));
        build(1,n,1);
        while(m--)
        {
            char str[10];
            int l,r,c;
            scanf("%s",str);
            if(str[0]=='Q')
            {
                scanf("%d%d",&l,&r);
                printf("%lld\n",query(l,r,1,n,1));
            }
            else
            {
                scanf("%d%d%d",&l,&r,&c);
                update(l,r,1,n,1,c);
            }
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值