ZOJ-3019 (伪lcs)

Puzzle


Time Limit: 2 Seconds      Memory Limit: 65536 KB


For sequences of integers a and b, if you can make the two sequences the same by deleting some elements in a and b, we call the remaining sequence "the common sub sequence". And we call the longest one the LCS.

 

Now you are given two sequences of integers a and b. You can arrange elements in a and b in any order. You are to calculate the max length of the LCS of each arrangement of a and b.

Input

Input will consist of multiple test cases. The first line of each case is two integers N(0 < N < 10000), M(0 < M < 10000) indicating the length of a and b. The second line is N 32-bit signed integers in a. The third line is M 32-bit signed integers in b.

Output

Each case one line. The max length of the LCS of each arrangement of a and b.

Sample Input

 

5 4
1 2 3 2 1
1 4 2 1

 

Sample Output

 

3

 

思路:刚开始以为是dp结果段错误,有一句话是 :  顺序可以自由变化  ,所以排序暴力即可

#include <iostream>
#include <algorithm>
using namespace std;
const int MAX = 1e4 + 5;
int a[MAX], b[MAX];
int main()
{
    int n, m;
    while(cin >> n >> m){
        for (int i = 0; i < n; i++){
            cin >> a[i];
        }
        for (int i = 0; i < m; i++){
            cin >> b[i];
        }
        sort(a, a + n);
        sort(b, b + m);
        int res = 0;
        int update = 0;
        for (int i = 0; i < n; i++){
            for (int j = update; j < m; j++){
                if (a[i] == b[j]){
                    update = j + 1;
                    res++;
                    break;                 //这里是break不是continue
                }
            }
        }
        cout << res << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值