2019--徐州网络赛B题

There are nn points in an array with index from 11 to nn, and there are two operations to those points.
1: 1 \ x1 x marking the point xx is not available
2: 2 \ x2 x query for the index of the first available point after that point (including xx itself) .

Output
Output the answer for each query.

样例输入 复制
5 3
1 2
2 2
2 1
样例输出 复制
3
1
//利用并查集模拟实现一个链表

#include<bits/stdc++.h>
using namespace std;
unordered_map<int,int> fa;
int find(int x)
{
  if(!fa.count(x)) return x;
  return fa[x]=find(fa[x]);
}
int main()
{
  int n,q,op,x;
  scanf("%d %d",&n,&q);
  while(q--)
  {
    scanf("%d %d",&op,&x);
    if(op==1)
    {
      fa[x]=find(x+1);
    }
    else
    {
      int res=find(x);
      if(res>n) res=-1;;
       printf("%d\n",res);
    }
  }
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值