HDU - 1394

第二天叫醒我的不是闹钟,是梦想!

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16

树状数组;求逆序数
首先题目是0----n-1.我们要把它对齐,读入的时候全部都加1,然后我们只要循环一遍1----n中的逆序数对有多少。然后这边有个思维,假设现在我们逆序数为ans,把a[i]移到最后,那么我们少了ans-a[i]个逆序数,但同时我们又多了n-a[i]-1个逆序数,所以答案就是ans-a[i]+n-a[i]-1;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e5+10;
const int INF=0x3f3f3f3f;
const int maxn=5000;
int a[N],c[N];
int n;
int lowbit(int x)
{
  return x&(-x);
}
void add(int i,int x)
{
  while(i<=maxn)
  {
    c[i]+=x;
    i+=lowbit(i);
  }
}
int sum(int i)
{
  int res=0;
  while(i>0)
  {
    res+=c[i];
    i-=lowbit(i);
  }
  return res;
}
int main()
{
  while(~scanf("%d",&n))
  {
      int ans=0;
      memset(c,0,sizeof(c));
      for(int i=1;i<=n;i++)
      {
        cin>>a[i];
        a[i]++;
        ans+=sum(maxn)-sum(a[i]);
        add(a[i],1);
      }
    //  cout<<ans<<endl;
      int  res=ans;
      for(int i=1;i<n;i++)
      {
          ans+=n-2*a[i]+1;   //这边+1是因为下标从1开始了
        //  cout<<ans<<endl;
          res=min(res,ans);
      }
      cout<<res<<endl;
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值