C - Phone List HDU - 1671----字典树

第二天叫醒我的不是闹钟,是梦想!

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

  1. Emergency 911
  2. Alice 97 625 999
  3. Bob 91 12 54 26
    In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
    Input
    The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
    Output
    For each test case, output “YES” if the list is consistent, or “NO” otherwise.
    Sample Input
    2
    3
    911
    97625999
    91125426
    5
    113
    12340
    123440
    12345
    98346
    Sample Output
    NO
    YES

//判断是不是前缀
//两种情况。
第一种先建911这个串,那么91125426就不可以了,因为肯定拨通了911
所以在建每个串结尾的地方打上标记。如果下次有串跑的时候,跑到了此处结束标记即不可行。

第二种就是91125426和911,先建第一个,再建第二个也不行。这个怎么判断呢,其实很简单,如果跑911的时候,跑到最后都没有建过一个节点,那么肯定是错的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e5+10;
int s[N][26],idx;
bool f[N];
char ch[N];
bool res;
int t,n;
bool  insert()
{
  int p=0;
  bool f1=true,f2=true;
  for(int i=0;i<strlen(ch);i++)
  {
    int u=ch[i]-'0';
    if(!s[p][u]) {s[p][u]=++idx;f1=false;}
    p=s[p][u];
    if(f[p]==1) f2=false;
  }
  f[p]=1;
  return !f1&&f2;
}
int main()
{
  scanf("%d",&t);
  while(t--)
  {
    memset(s,0,sizeof s);
    memset(f,0,sizeof f);
    idx=0;res=true;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
      scanf("%s",ch);
      if(!insert()) res=false;
    }
    if(res==false) puts("NO");
    else puts("YES");
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值