问题 D: MooBuzz----二分+容斥

题目描述
Farmer John’s cows have recently become fans of playing a simple number game called “FizzBuzz”. The rules of the game are simple: standing in a circle, the cows sequentially count upward from one, each cow saying a single number when it is her turn. If a cow ever reaches a multiple of 3, however, she should say “Fizz” instead of that number. If a cow reaches a multiple of 5, she should say “Buzz” instead of that number. If a cow reaches a multiple of 15, she should say “FizzBuzz” instead of that number. A transcript of the first part of a game is therefore:
1, 2, Fizz, 4, Buzz, Fizz, 7, 8, Fizz, Buzz, 11, Fizz, 13, 14, FizzBuzz, 16

Having a slightly more limited vocabulary, the version of FizzBuzz played by the cows involves saying “Moo” instead of Fizz, Buzz, and FizzBuzz. The beginning of the cow version of the game is therefore

1, 2, Moo, 4, Moo, Moo, 7, 8, Moo, Moo, 11, Moo, 13, 14, Moo, 16

Given N (1≤N≤109), please determine the Nth number spoken in this game.

SCORING
Test cases 2-5 satisfy N≤106.
输入
The input consists of a single integer, N.
输出
Please print out the Nth number spoken during the game.
样例输入 Copy
4
样例输出 Copy
7
提示
The 4th number spoken is 7. The first 4 numbers spoken are 1, 2, 4, 7, since we skip over any time a cow says “Moo”.

解析:对于第n个数,只要计算第n个数+之前被跳过去的数cnt,就可以得到答案。
cnt 显然等于 n 内 3 的倍数 + 5 的倍数 +15的倍数,但是15 = 3 * 5,所以15不需要重复统计(已经在 3 的倍数中统计过了)。但是我们重复统计了 3 和 5 的公倍数(统计了 2 次),于是我们就要减去同时是 3 的倍数和 5 的倍数 的 个数即可得到cnt。
我们就可以在O(logN)时间内用二分搜索解决此题。


#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll N=1e18;
ll  t;
ll check(ll n)
{
	ll a=n/3;
	ll b=n/5;
	ll c=n/15;
	ll cnt=a+b-c;
	return n-cnt>=t;//n-cnt表示符合的数
}
int main()
{
	scanf("%lld",&t);
	ll l=1,r=N;
	while(l<=r)
	{
		ll mid=l+r>>1;
		if(check(mid)) r=mid-1;
		else l=mid+1;
	}
	cout<<l<<endl;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值