I n v i t a t i o n C a r d s Invitation\ Cards Invitation Cards
Time Limit: 5 Seconds | Memory Limit: 65536 KB |
---|
Problem Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X’ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.
All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210
Source: Central Europe 1998
题目大意:
n个学生要从Central Checkpoint Stop (CCS)[编号为1]到各个车站做志愿活动,最后还要回到起点。一共有n个志愿点,每个学生一个点,给出m条路径,要求计算出来回的最小花费。
分析:
显而易见这是一道求单源最短路径的题,算法就是Bellman-Ford或者Dijkstra,只要算出原图到各个点的最短路径和,然后把所有边反向,再算一次最短路径和,把两个最短路径和加起来就是答案了。
只是这道题的数据量比较大,最多有1000000个点,1000000条边。
空间方面:存图可以用链式前向星,节省空间。
时间方面:普通的Bellman-Ford(O(nm))或者Dijkstra(O(n2))对于最大规模的数据可能会超时,所以得要对普通最短路算法进行优化,对于Bellman-Ford算法可以进行队列优化,可以大量减少不必要的操作,减少运行时间(如果卡数据的话最坏情况下还是O(nm)),而对于Dijkstra算法可以用堆进行优化,时间复杂度优化到O(nlogn)。
由于本题数据较弱,不加优化也能过…
Bellman-Ford 无优化(740ms,27528KB)
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1e6+7;
const int INF = 0x3f3f3f3f;
struct EDGE{
int from,to,cost;
};
EDGE edge[2][maxn];
int dist[maxn];
int T,n,m;
void add_edge(int u,int v,int w,int k){ //存所有边
edge[0][k].from = u;
edge[0][k].to = v;
edge[1][k].from = v;
edge[1][k].to = u;
edge[0][k].cost = edge[1][k].cost = w;
}
void input(){
scanf("%d %d",&n,&m);
for(int i=1;i<=m;i++){
int u,v,w;
scanf("%d %d %d",&u,&v,&w);
add_edge(u,v,w,i);
}
}
int Bellman_Ford(int op){
int ans = 0;
memset(dist,INF,sizeof(dist));
dist[1] = 0;
while(true){
bool update = false;
for(int i=1;i<=m;i++){
EDGE u = edge[op][i];
if(dist[u.to]>dist[u.from]+u.cost){
update = true;
dist[u.to] = dist[u.from] + u.cost;
}
}
if(!update) break;
}
for(int i=1;i<=n;i++) ans+=dist[i];
return ans;
}
int main(){
scanf("%d",&T);
while(T--){
input();
printf("%d\n",Bellman_Ford(0)+Bellman_Ford(1));
}
return 0;
}
Bellman-Ford+队列优化 (260 ms,39344KB)
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn = 1e6+7;
const int INF = 0x3f3f3f3f;
struct EDGE{
int to,cost,next;
};
int head[2][maxn];
EDGE edge[2][maxn];
int dist[maxn],vis[maxn];
int T,n,m;
void init(){
memset(head,255,sizeof(head));
}
void add_edge(int u,int v,int w,int k){ //链式前向星 记录原图和边反向之后的图
edge[0][k].next = head[0][u];
edge[0][k].to = v;
edge[0][k].cost = w;
head[0][u] = k;
edge[1][k].next = head[1][v];
edge[1][k].to = u;
edge[1][k].cost = w;
head[1][v] = k;
}
void input(){
scanf("%d %d",&n,&m);
for(int i=1;i<=m;i++){
int u,v,w;
scanf("%d %d %d",&u,&v,&w);
add_edge(u,v,w,i);
}
}
int SPFA(int op){
int ans = 0;
memset(vis,0,sizeof(vis));
memset(dist,INF,sizeof(dist));
queue<int> que;
que.push(1);
vis[1] = 1; dist[1] = 0;
while(!que.empty()){
int now = que.front();
que.pop(); vis[now] = 0;
for(int i=head[op][now];i!=-1;i=edge[op][i].next){
EDGE u = edge[op][i];
if(dist[now]+u.cost<dist[u.to]){
dist[u.to] = dist[now] + u.cost;
if(!vis[u.to]){
vis[u.to] = 1;
que.push(u.to);
}
}
}
}
for(int i=1;i<=n;i++) ans+=dist[i];
return ans;
}
int main(){
scanf("%d",&T);
while(T--){
init(); input();
printf("%d\n",SPFA(0)+SPFA(1));
}
return 0;
}
Dijkstra 无优化(2190ms,39248KB)
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 1e6+7;
const int INF = 0x3f3f3f3f;
struct EDGE{
int to,cost,next;
};
int head[2][maxn];
EDGE edge[2][maxn];
int dist[maxn],used[maxn];
int T,n,m;
void init(){
memset(head,255,sizeof(head));
}
void add_edge(int u,int v,int w,int k){ //链式前向星 记录原图和边反向之后的图
edge[0][k].next = head[0][u];
edge[0][k].to = v;
edge[0][k].cost = w;
head[0][u] = k;
edge[1][k].next = head[1][v];
edge[1][k].to = u;
edge[1][k].cost = w;
head[1][v] = k;
}
void input(){
scanf("%d %d",&n,&m);
for(int i=1;i<=m;i++){
int u,v,w;
scanf("%d %d %d",&u,&v,&w);
add_edge(u,v,w,i);
}
}
int Dijkstra(int op){
memset(dist,INF,sizeof(dist));
memset(used,0,sizeof(used));
dist[1] = 0;
while(true){
int pos = -1;
for(int i=1;i<=n;i++) if(!used[i]&&(pos==-1||dist[i]<dist[pos])) pos = i;
if(pos==-1) break;
used[pos] = 1;
for(int j=head[op][pos];j!=-1;j=edge[op][j].next){
EDGE now = edge[op][j];
dist[now.to] = min(dist[now.to],dist[pos]+now.cost);
}
}
int ans = 0;
for(int i=1;i<=n;i++) ans+=dist[i];
return ans;
}
int main(){
scanf("%d",&T);
while(T--){
init(); input();
printf("%d\n",Dijkstra(0)+Dijkstra(1));
}
return 0;
}
Dijkstra+heap优化(190ms,35416KB)
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 1e6+7;
const int INF = 0x3f3f3f3f;
struct EDGE{
int to,cost,next;
};
int head[2][maxn];
EDGE edge[2][maxn];
int dist[maxn];
int T,n,m;
void init(){
memset(head,255,sizeof(head));
}
void add_edge(int u,int v,int w,int k){ //链式前向星 记录原图和边反向之后的图
edge[0][k].next = head[0][u];
edge[0][k].to = v;
edge[0][k].cost = w;
head[0][u] = k;
edge[1][k].next = head[1][v];
edge[1][k].to = u;
edge[1][k].cost = w;
head[1][v] = k;
}
void input(){
scanf("%d %d",&n,&m);
for(int i=1;i<=m;i++){
int u,v,w;
scanf("%d %d %d",&u,&v,&w);
add_edge(u,v,w,i);
}
}
int Dijkstra(int op){
memset(dist,INF,sizeof(dist));
typedef pair<int,int> PAIR;
priority_queue<PAIR> que; //堆优化
dist[1] = 0;
que.push(make_pair(dist[1],1));
while(!que.empty()){
PAIR now = que.top();
que.pop();
if(dist[now.second]==now.first){
for(int i=head[op][now.second];i!=-1;i=edge[op][i].next){
EDGE u = edge[op][i];
if(dist[now.second]+u.cost<dist[u.to]){
dist[u.to] = dist[now.second] + u.cost;
que.push(make_pair(dist[u.to],u.to));
}
}
}
}
int ans = 0;
for(int i=1;i<=n;i++) ans+=dist[i];
return ans;
}
int main(){
scanf("%d",&T);
while(T--){
init(); input();
printf("%d\n",Dijkstra(0)+Dijkstra(1));
}
return 0;
}