HDU 3555 Bomb【数位DP】

B o m b Bomb Bomb

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 26150Accepted Submission(s): 9915

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500

Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.

Author
fatboy_cw@WHU

Source
2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

问题描述:

统计1~n之间的数中含有‘49’的有多少个,数位DP模板上

两种方案:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 34;
int T;
LL n,dp[maxn][maxn][2],num[maxn];
LL dfs(int pos,bool limit,int pre,bool ok){
    if(pos==-1) return ok;
    if(!limit&&dp[pos][pre][ok]!=-1) return dp[pos][pre][ok];
    int up = limit?num[pos]:9;
    LL res = 0;
    for(int i=0;i<=up;i++) res+=dfs(pos-1,limit&&(i==num[pos]),i,ok||(pre==4&&i==9));
    if(!limit) dp[pos][pre][ok] = res;
    return res;
}
LL solve(LL x){
    int pos = 0;
    while(x){
        num[pos++] = x%10;
        x/=10;
    }
    return dfs(pos-1,true,0,false);
}
int main(){
    scanf("%d",&T);
    memset(dp,255,sizeof(dp));
    while(T--){
        scanf("%lld",&n);
        printf("%lld\n",solve(n));
    }
    return 0;
}

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 34;
int T;
LL n,dp[maxn][3],num[maxn];
LL dfs(int pos,bool limit,int sta){
    if(pos==-1) return sta==2;
    if(!limit&&dp[pos][sta]!=-1) return dp[pos][sta];
    int up = limit?num[pos]:9;
    LL res = 0;
    for(int i=0;i<=up;i++){
        int tsta = 0;
        if(sta==2) tsta = 2;
        else if(sta==1&&i==9) tsta = 2;
        else if(i==4) tsta = 1;
        res+=dfs(pos-1,limit&&(i==num[pos]),tsta);
    }
    if(!limit) dp[pos][sta] = res;
    return res;
}
LL solve(LL x){
    int pos = 0;
    while(x){
        num[pos++] = x%10;
        x/=10;
    }
    return dfs(pos-1,true,0);
}
int main(){
    scanf("%d",&T);
    memset(dp,255,sizeof(dp));
    while(T--){
        scanf("%lld",&n);
        printf("%lld\n",solve(n));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值