week15——作业(字符串,完结撒花)

ZJM 与霍格沃兹 :

问题描述

题目简述

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

输入/输出格式

输入格式:
首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
输出格式:
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

样例

输入样例:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
输出样例:
light the wand
accio
what?
what?

问题分析

解题思路

本题是字符串哈希算法的直接应用。具体来说,就是使用Bkdr Hash算法,设置种子和模数(这里直接使用了unsigned long long自然溢出),将输入的咒语和内容分别映射成一个整数,并保存在一个map中,然后,根据输入的内容,用相同的方式进行映射,从字典中找到该内容对应的标号,并输出内容即可。如果不存在,那么输出what?

参考代码
#include <string>
#include <map>
#include <iostream>

using namespace std;

const int seed=17;
map<unsigned long long,int> mp;
string text[200005];

unsigned long long hashstr(string s)
{
	unsigned long long h=0;
	for(int i=0;i<s.length();i++)
	{
		h=h*seed+(int)s[i];
	}
	return h;
}

int main()
{
	int a,b;
	a=0;
	for(;;)
	{
		string str1,str2,str;
		getline(cin,str);
		int point1=str.find("[",0);
		int point2=str.find("]",point1+1);
	    if(point1==string::npos||point2==string::npos) break;
		str1=str.substr(point1+1,point2-point1-1);
		str2=str.substr(point2+2);
		a++;
		text[a]=str2;
		unsigned long long hh=hashstr(str1);
		mp.insert(make_pair(hh,a));
		a++;
		text[a]=str1;
		hh=hashstr(str2);
		mp.insert(make_pair(hh,a));
	}
	cin>>b;
	getchar();
	for(int i=1;i<=b;i++)
	{
		string ss;
		getline(cin,ss);
		if(ss[0]=='[') 
		{
			ss.erase(ss.end()-1);
			ss.erase(ss.begin());
		}
		unsigned long long hh=hashstr(ss);
		if(mp.find(hh)!=mp.end())
		{
			int p=mp.find(hh)->second;
			cout<<text[p]<<endl;
		}
		else cout<<"what?"<<endl;
	}
	return 0;
}

心得体会

字符串哈希算法的直接应用,算是一个模板题了,总体来说这个算法还是非常容易理解的。

ZJM 与生日礼物:

问题描述

题目简述

ZJM 收到了 Q老师 送来的生日礼物,但是被 Q老师 加密了。只有 ZJM 能够回答对 Q老师 的问题,Q老师 才会把密码告诉 ZJM。

Q老师 给了 ZJM 一些仅有 01 组成的二进制编码串, 他问 ZJM:是否存在一个串是另一个串的前缀.

输入/输出格式

输入格式:
多组数据。每组数据中包含多个仅有01组成的字符串,以一个9作为该组数据结束的标志。
输出格式:
对于第 k 组数据(从1开始标号),如果不存在一个字符串使另一个的前缀,输出"Set k is immediately decodable",否则输出"Set k is not immediately decodable"。
每组数据的输出单独一行

样例

输入样例:
01
10
0010
0000
9
01
10
010
0000
9
输出样例:
Set 1 is immediately decodable
Set 2 is not immediately decodable

问题分析

解题思路

本题是字典树的一个直接应用。由于字典树是将字符串的每一个部分依次保存,因此很容易可以判断前缀字符串,我们的方法是边插入边判断,如果发现,当前插入的字符串已经到了字符串结尾,并且当前结点已经被之前的字符串使用过,并且不为字符串尾,则说明,当前字符串为前面插入的字符串的前缀字符串,如果当前插入字符串没有到结尾,但是插入的时候遇到了之前插入的字符串的结尾,则说明之前插入的字符串为当前字符串的前缀字符串,这两种请况一旦出现即为不可解码。当所有字符串都插入后,以上情况没有出现,则可解码。

参考代码
#include <iostream>
#include <cstring>
#include <string>

using namespace std;

struct Trie
{
	static const int N=1010,charset=5;
	int tot,root,child[N][charset],flag[N];
    Trie()
	{
		memset(child,-1,sizeof(child));
		root=0;
		tot=0;
	};
	void clear()
	{
		memset(child,-1,sizeof(child));
		root=0;
		tot=0;
	};
	int solve(string s)
	{
		int jud=0;
		int now=root;
		for(int i=0;i<s.length();i++)
		{
			int x=s[i]-'0';
			if(child[now][x]==-1)
			{
				child[now][x]=++tot;
				flag[now]=0;
			}
			else if(i==s.length()-1||flag[child[now][x]]) jud=1;
			now=child[now][x];
		}
		flag[now]=1;
		return jud;
	};
};

int main()
{
	string str;
	Trie tr;
	tr.clear();
	bool can=false;
	int count=1;
	while(cin>>str)
	{
		if(str=="9")
		{
			if(!can) cout<<"Set "<<count<<" is immediately decodable"<<endl;
			else cout<<"Set "<<count<<" is not immediately decodable"<<endl;
			count++;
			can=false;
			tr.clear();
			continue; 
		}
		if(tr.solve(str)) can=true;
	}
	return 0;
}

心得体会

字典树的应用,通过这个题,我对字典树的结构有了更加深入的理解和认识,也对字典树的应用有了更加深刻的理解和认识。

ZJM 与纸条:

问题描述

题目简述

ZJM 的女朋友是一个书法家,喜欢写一些好看的英文书法。有一天 ZJM 拿到了她写的纸条,纸条上的字暗示了 ZJM 的女朋友 想给 ZJM 送生日礼物。ZJM 想知道自己收到的礼物是不是就是她送的,于是想看看自己收到的礼物在纸条中出现了多少次。

输入/输出格式

输入格式:

第一行输入一个整数代表数据的组数

组数据第一行一个字符串 P 代表 ZJM 想要的礼物, 包含英语字符 {‘A’, ‘B’, ‘C’, …, ‘Z’}, 并且字符串长度满足 1 ≤ |P| ≤ 10,000 (|P| 代表字符串 P 的长度).
接下来一行一个字符串 S 代表 ZJM 女朋友的纸条, 也包含英语字符 {‘A’, ‘B’, ‘C’, …, ‘Z’}, 满足 |P| ≤ |S| ≤ 1,000,000.

输出格式:
输出一行一个整数代表 P 在 S中出现的次数.

样例

输入样例:
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
输出样例:
1
3
0

问题分析

解题思路

这个题是KMP问题,我这里直接套用的KMP算法的板子写了,所实话对这个算法的原理还不是很理解,但是里面的next数组和判断过程都是知道怎么求的。还是要再次落实。

参考代码
#include <iostream>
#include <string>
#include <cstring>

using namespace std;

int Next[10010];

void getnext(string P)
{
	Next[0]=0;
	for(int i=1,j=0;i<P.length();i++)
	{
		while(j&&P[i]!=P[j]) j=Next[j-1];
		if(P[i]==P[j]) j++;
		Next[i]=j;
	}
}

int KMP(string S,string P)
{
	int len1=S.length();
	int len2=P.length();
	int count=0;
	getnext(P);
	for(int i=0,j=0;i<len1;i++)
	{
		while(j&&S[i]!=P[j]) j=Next[j-1];
		if(S[i]==P[j]) j++;
		if(j==len2)
		{
			count++;
			j=Next[j-1];
		}
	}
	return count;
}

int main()
{
	int n;
	cin>>n;
	getchar();
	for(int i=1;i<=n;i++)
	{
		string S,P;
		cin>>P;
		cin>>S;
		memset(Next,0,sizeof(Next)); 
		cout<<KMP(S,P)<<endl;
	}
	return 0;
}

心得体会

暂时也没有啥心得体会,毕竟还是没太弄懂算法。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值