POJ 3126 Prime Path(BFS)

传送门:http://poj.org/problem?id=3126

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input

3
1033 8179
1373 8017
1033 1033
Sample Output

6
7
0

题意

  把一个四位数的质数转化为另一个四位数的质数的最小步数,每次你可以更改 该四位质数 千位 或者 百位 或者 十位 或者 个位 的数字,但是更改后的数字必须是质数,如果不能转化,就输出Impossible。

思路

  BFS暴搜即可

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<vector>
#include<stack>
#include<queue>
#include<ctime>
#define ll long long
#define ld long double
#define ull unsigned long long
using namespace std;
const int maxn = 100010;
const int inf = 0x3f3f3f3f3f;
const ll lnf = 0x3f3f3f3f3f3f3f;
int lp,pri[maxn];
bool v[maxn],use[maxn];
int p[8],q[8];
int ans;
struct In
{
    int nmb;
    int step;
}now,nx;
void primes()
{
    memset(v,true,sizeof(v));
    lp = 0;
    v[0] = v[1] = 0;
    for(int i=2;i<maxn;i++){
        if(v[i])    pri[lp++] = i;
        for(int j=0;j<lp&&i*pri[j]<maxn;j++){
            v[i*pri[j]] = 0;
            if(i%pri[j]==0)   break;
        }
    }
}
int BFS(int x,int y)
{
    queue<In> p;
    now.nmb = x,now.step = 0;
    p.push(now);

    while(!p.empty()){
        now = p.front();
        if(now.nmb==y)  return now.step;
        int a = now.nmb - (now.nmb/1000)*1000;	//更改千位
        for(int i=1000;i<10000;i+=1000){
            if(v[a+i]&&!use[a+i]){
                use[a+i] = true;
                nx.nmb = a + i;
                nx.step = now.step+1;
                p.push(nx);
            }
        }
        int b = (now.nmb/1000)*1000 + now.nmb%100;	//更改百位
        for(int i=0;i<1000;i+=100){
            if(v[b+i]&&!use[b+i]){
                use[b+i] = true;
                nx.nmb = b + i;
                nx.step = now.step+1;
                p.push(nx);
            }
        }
        int c = now.nmb/100*100 + now.nmb%10;	//更改十位
        for(int i=0;i<100;i+=10){
            if(v[c+i]&&!use[c+i]){
                use[c+i] = true;
                nx.nmb = c + i;
                nx.step = now.step+1;
                p.push(nx);
            }
        }
        int d = now.nmb/10*10;	//更改个位
        for(int i=1;i<10;i++){
            if(v[d+i]&&!use[d+i]){
                use[d+i] = true;
                nx.nmb = d + i;
                nx.step = now.step+1;
                p.push(nx);
            }
        }
        p.pop();
    }
    return -1;
}
int main(void)
{
    int t,a,b;
    primes();
    scanf("%d",&t);
    while(t--){
        memset(use,false,sizeof(use));
        scanf("%d%d",&a,&b);
        int ans = BFS(a,b);
        if(ans!=-1) printf("%d\n",ans);
        else printf("Impossible\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逃夭丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值