东软学习小组成员:夜枫
给定两个均不超过9的正整数a和n,要求编写程序求a+aa+aaa++⋯+aa⋯a(n个a)之和。
输入格式:
输入在一行中给出不超过9的正整数a和n。
输出格式:
在一行中按照“s = 对应的和”的格式输出。
输入样例:
2 3
输出样例:
s = 246
#include<iostream>
#include<math.h>
using namespace std;
int main(void){
unsigned a,n;
cin>>a>>n;
if(a>9||n>9){
return 0;
}
int i=0;
int res=0;//结果
int temp=0;//临时变量
while(i<n){
i++;
temp=temp*10+a;
res+=temp;
}
cout<<"s = "<<res;
}