2016年ICPC中国大陆区域赛(青岛)A题

题目网址点击进入

Problem Description
Recently, paleoanthropologists have found historical remains on an island in the Atlantic Ocean. The most inspiring thing is that they excavated in a magnificent cave and found that it was a huge tomb. Inside the construction,researchers identified a large number of skeletons, and funeral objects including stone axe, livestock bones and murals. Now, all items have been sorted, and they can be divided into N types. After they were checked attentively, you are told that there are Ai items of the i-th type. Further more, each item of the i-th type requires Bi million dollars for transportation, analysis, and preservation averagely. As your job, you need to calculate the total expenditure.

Input
The first line of input contains an integer T which is the number of test cases. For each test case, the first line contains an integer N which is the number of types. In the next N lines, the i-th line contains two numbers Ai and Bi as described above. All numbers are positive integers and less than 101.

Output
For each case, output one integer, the total expenditure in million dollars.

Sample Input
1
2
1 2
3 4

Sample Output
14

大致题意:
输入一个 t,接下来 t 组数据,每组数据一个 n ,接下来 n 行,每行给出两个数,求每行两个数乘积,所有的行数乘积总和为多少

思路
大水题,也就我这种半年没学习的菜鸡水着找找自信,一个sum=0的求和而已

代码

#include<bits/stdc++.h>
using namespace std;
typedef long long int LLD;
int main()
{
    LLD t;
    scanf("%lld",&t);
    while (t--)
    {
        LLD n,sum=0;
        scanf("%lld",&n);
        while (n--)
        {
            LLD a,b;
            scanf("%lld %lld",&a,&b);
            sum=sum+(a*b);
        }
        printf("%lld\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值