差分约束加最短路

Layout
Time Limit: 1000MS         Memory Limit: 65536K
Total Submissions: 10278         Accepted: 4946
Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input

4 2 1

1 3 10

2 4 20

2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
Source

USACO 2005 December Gold

题目大意:

一共有n头牛,有ml个关系好的牛的信息,有md个关系不好的牛的信息,对应输入的第一行的三个元素,接下来ml行,每行三个元素A,B,D,表示A牛和B牛相距不希望超过D,接下来md行,每行三个元素A,B,D表示A牛和B牛的相距至少要有D才行。求1号牛和n号牛的最大距离,如果距离无限大输出-2,如果无解输出-1。

思路:

1、因为我们要求1号牛和n号牛的最大距离,那么我们希望得到这样一个不等式(假设n==5):①-⑤<=x,那么这个x就是1号牛和n号牛的最大距离。

2、那么我们引入一个差分约束系统的相关概念:

差分约束系统问题,能够将问题转化为最短路问题。以下给出转化过程:

假设有这样的三个条件:

那么我们可以将不等式1和不等式2相加得到:

那么如果想要得到x1和x3的最大差值,那么其实就是取min(k1+k2,k3);

其实问题我们可以将问题转化成图论,将x1,x2,x3看成三个点x1,x2,x3,对应三条边的建立就根据三个不等式来建立,那么边权值如何取呢?显然我们想要最大差值,我们就需要取最大值,那么图可以建立成这样:

那么我们上述过程将不等式1和不等式2相加,然后和不等式3比较值的过程,其实就是最短路计算过程中的判断能否松弛的过程。

那么我们就可以根据不等式建立有向图,然后再通过有向图计算1号点到n号点的最短路,其值就是x1与xn的最大差值。

3、然后我们再回归到这个问题上来。

对应ml条信息:

①牛A和牛B的距离不想超过D,那么建立不等式:posA-posB<=D;加入到图中直接add(A,B,D)即可、

对应md条信息:

②牛A和牛B的距离至少要为D,那么建立不等式:posA-posB>=D,那么我们左右两边同乘-1有:posB-posA<=-D,那么加入到图中add(B,A,-D)即可。

4、图建立好之后直接跑最短路即可。

对应输出:

①如果dis【n】==inf,输出-2;

②否则输出dis【n】;

③如果在跑SPFA过程中发现了负环,说明问题无解,那么输出-1.

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<cmath>
#include<string>
#include<map>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long ll;

struct node{
	ll y;
	ll d;
	ll next_s;
}side[22000];
ll n,head[1001],cnt,cn[1001],flag[1001];
ll dis[1010];
void init(){
	memset(head,-1,sizeof(head));
	cnt=0;
}

void add(ll x,ll y,ll d){
	side[cnt].y=y;
	side[cnt].d=d;
	side[cnt].next_s=head[x];
	head[x]=cnt++;
}

ll spfa(ll x){
	for(int i=1;i<=n;i++){
		flag[i]=0;
		cn[i]=0;
		dis[i]=INF;
	}
//注释部分不能用
//memset(flag,0,sizeof(flag));
//memset(cn,0,sizeof(cn));
//memset(dis,INF,sizeof(dis));
	flag[x]=1;
	dis[x]=0;
	queue<ll>p;
	p.push(x);
	cn[x]++;
	while(!p.empty()){
		ll temp=p.front();
		p.pop();
		flag[temp]=0;
		for(int i=head[temp];i!=-1;i=side[i].next_s){
			if(dis[side[i].y]>dis[temp]+side[i].d){
				dis[side[i].y]=dis[temp]+side[i].d;
				if(!flag[side[i].y]){
					p.push(side[i].y);
					flag[side[i].y]=1;
					cn[side[i].y]++;
					if(cn[side[i].y]>=n){
						return -1;
					}
				}
			}	
		}
	}
	return dis[n];
}

int main(){
  	ll ml,md;
  	while(cin>>n>>ml>>md){
  	init();
  	for(ll i=0;i<ml;i++){
  		ll a,b,c;
  		cin>>a>>b>>c;
  		add(a,b,c);
	}
  	for(int i=0;i<md;i++){
  		ll a,b,c;
  		cin>>a>>b>>c;
  		add(b,a,-c);
	}
  	ll book=spfa(1);
  	if(book==-1){
  		cout<<-1<<endl;
	  }
	 else if(book==INF){
	 	cout<<-2<<endl;
	 }
	 else cout<<dis[n]<<endl;
	 }
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值