POJ 3264 Balanced Lineup

64 篇文章 0 订阅
1 篇文章 0 订阅

POJ 3264 Balanced Lineup

题目链接

Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

两种办法:
1.RMQ模板题,AC代码如下:

#include <cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
const int N=5e5+5;
int n,q,l,r,dp1[N][50],dp2[N][50],a[N];
void rmq_init()
{
    for(int i=1;i<=n;i++)
        dp1[i][0]=dp2[i][0]=a[i];
    for(int j=1;(1<<j)<=n;j++)
        for(int i=1;i+(1<<j)-1<=n;i++){
            dp1[i][j]=min(dp1[i][j-1],dp1[i+(1<<j-1)][j-1]);
            dp2[i][j]=max(dp2[i][j-1],dp2[i+(1<<j-1)][j-1]);
        }
}

int rmqmin(int l,int r)
{
    int k=log2(r-l+1);
    return min(dp1[l][k],dp1[r-(1<<k)+1][k]);
}

int rmqmax(int l,int r)
{
    int k=log2(r-l+1);
    return max(dp2[l][k],dp2[r-(1<<k)+1][k]);
}

int main()
{
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    rmq_init();
    while(q--){
        scanf("%d%d",&l,&r);
        printf("%d\n",rmqmax(l,r)-rmqmin(l,r));
    }
}

2.线段树,消耗的内存小一些,时间一样

#include <cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=5e4+5;
struct node{
    int mx,mn;
}tree[N<<2];
int n,q,l,r,mn,mx,a[N];
void pushup(int i)
{
     tree[i].mx=max(tree[i<<1].mx,tree[(i<<1)+1].mx);
     tree[i].mn=min(tree[i<<1].mn,tree[(i<<1)+1].mn);
}

void build(int i,int l,int r){
    if(l==r){
        tree[i].mn=tree[i].mx=a[l];
        return ;
    }
    int mid=l+(r-l)/2;
    build(i<<1,l,mid);
    build((i<<1)+1,mid+1,r);
    pushup(i);
}

void query(int i,int l,int r,int x,int y){
    if(x<=l&&r<=y){
        mx=max(mx,tree[i].mx);
        mn=min(mn,tree[i].mn);
        return ;
    }
    int mid=l+(r-l)/2;
    if(x<=mid) query(i<<1,l,mid,x,y);
    if(y>mid) query((i<<1)+1,mid+1,r,x,y);
}

int main() {
	scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    build(1,1,n);
    while(q--){
        scanf("%d%d",&l,&r);
        mn=1e9,mx=-1e9;
        query(1,1,n,l,r);
        printf("%d\n",mx-mn);
    }
	return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺 崽

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值