The Triangle——POJ-1163(动态规划)

1.题目

在这里插入图片描述

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30

2.题目分析

(1)题意说明

从顶到底找到一条路 ,每行一个数,只可以在斜上和斜下方向走,使这条路上的数字之和最大。

(2)

数字三角形问题,采用动态规划求解
自顶向下或自底向上找递推关系:
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
1.设置变量
a[r][j]表示第r行第j个数字(r,j从1开始算)
目标 maxsum(r,j):从a[r][j]到底边的各条路径中,最佳路径的数字之和
2.递推关系
从下往上,d(i,j) = a(i,j) + max{d(i+1,j),d(i+1,j+1)}
a和d可以用一个变量表示

(2)代码

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
	int n;
	int a[100][100];
	
	cin>>n;
	for(int i=0;i<n;i++){//输入原始数据
		for(int j=0;j<=i;j++)
			cin>>a[i][j];
	}
	
	for(int i=n-2;i>=0;i--){//从倒数第二行开始遍历
		for(int j=0;j<=i;j++){
			a[i][j]+=(a[i+1][j]>a[i+1][j+1])?a[i+1][j]:a[i+1][j+1];
		}
	}
	cout<<a[0][0]<<endl;//代表从第0行到底的最佳路径之和
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值