Description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
Code
#include <iostream>
using namespace std;
#define N 101
int route[N][N]={0};
int data[N][N]={0};
int sum(int ,int ,int );
int main()
{
int i,j,n;
cin>>n;
for(i=1;i<n+1;i++)
for(j=1;j<=i;j++)
{cin>>data[i][j];route[i][j]=-1;}
cout<<sum(1,1,n);cin>>n;
return 0;
}
int sum(int i,int j,int n)
{
if(i==n)
return data[i][j];
if(route[i+1][j]==-1)
route[i+1][j]=sum(i+1,j,n);
if(route[i+1][j+1]==-1)
route[i+1][j+1]=sum(i+1,j+1,n);
if(route[i+1][j]<route[i+1][j+1])
return route[i+1][j+1]+data[i][j];
else
return route[i+1][j]+data[i][j];
#include <iostream>
using namespace std;
#define N 101
int route[N][N]={0};
int data[N][N]={0};
int sum(int ,int ,int );
int main()
{
int i,j,n;
cin>>n;
for(i=1;i<n+1;i++)
for(j=1;j<=i;j++)
{cin>>data[i][j];route[i][j]=-1;}
cout<<sum(1,1,n);cin>>n;
return 0;
}
int sum(int i,int j,int n)
{
if(i==n)
return data[i][j];
if(route[i+1][j]==-1)
route[i+1][j]=sum(i+1,j,n);
if(route[i+1][j+1]==-1)
route[i+1][j+1]=sum(i+1,j+1,n);
if(route[i+1][j]<route[i+1][j+1])
return route[i+1][j+1]+data[i][j];
else
return route[i+1][j]+data[i][j];