题目描述
输入多个字符串,输出最长字符串。要求定义并使用函数maxLenStr(),
void maxLenStr(char *str[], int n, int *max)
{
从字符串数组str中找出最长的一个字符串,并将其下标存入形参指针max所指内存。
}
输入
输入有多行,每行一个字符串,每个字符串长度不超过80,输入最多不超过100行,用****作为结束输入的标志,该行输入不用处理。
输出
输出最长的一个字符串。
样例输入 Copy
L love C programming ACM/ICPC study hard ****
样例输出 Copy
L love C programming
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cmath>
#include<iomanip>
#include<algorithm>
using namespace std;
void maxLenStr(char *str, char *max)
{
int len1 = strlen(str);
int len2 = strlen(max);
if(len1 > len2)
strcpy(max,str);
}
int main(void){
char c;
char str[110],max[110];
memset(max,'\0',sizeof(max));
for(int i = 0; i < 110; i++){
memset(str,'\0',sizeof(str));
for(int j = 0; j < 110; j++){
scanf("%c",&c);
if(c == '\n')
break;
str[j] = c;
}
if(strcmp(str,"****") == 0)//{当stcmp(a,b)> 0,a>b ;
// stcmp(a,b)<0 ,a < b;
//stcmp(a,b) == 0, a = b;
//比较字符数组char[]
break;
}
maxLenStr(str,max);
}
printf("%s\n",max);
return 0;
}