PAT1011

46 篇文章 0 订阅

原题

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

思路

翻译:随着2010年国际足联世界杯的举行,全世界的足球迷们都变得越来越兴奋,因为来自最好球队的最好球员们正在为南非世界

杯奖杯而战。同样,足球投注的球迷们也把他们的钱放在了他们的嘴上,通过各种形式的世界杯赌注。

中国足球彩票提供了“三赢”游戏。获胜的规则很简单:先从三个游戏中选择一个。然后,对于每一个选定的游戏,赌三个可能的结

果之一,W代表赢,T代表平局,L代表输。每个结果都有一个奇数。胜利者的奇数是三个赔率乘以65%的乘积。

例如,3场比赛的赔率如下:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

为了获得最大的利润,第三局必须买W,第二局买T,第一局买T。如果每注2元,则最大利润为(4.1×3.1×2.5×65%-1)×2=39.31元(精确到小数点后2位)。

输入:每个输入案例包含一个输入案例。每个案例包含3个游戏的投注信息。每一场比赛都有三个不同的赔率,分别对应于W、T和L。

输出:对于每个测试用例,在一行中打印每个游戏的最佳赌注,最大利润精确到小数点后2位。字符和数字必须用一个空格隔开。

题解

#include <algorithm>
#include <cmath>
#include <iostream>
#include <map>
#include <set>
#include <string>
#include <unordered_map>
#include <unordered_set>
#include <vector>

using namespace std;

int main() {
  vector<char> vec(3);
  vec[0] = 'W';
  vec[1] = 'T';
  vec[2] = 'L';
  double ans = 1.0;
  int p[3], index, c = 0;
  for (int i = 0; i < 3; ++i) {
    double temp = 0.0;
    for (int j = 0; j < 3; ++j) {
      double x;
      cin >> x;
      if (x >= temp) {
        temp = x;
        index = j;
      }
    }
    p[c++] = index;
    ans *= temp;
  }
  for (int i = 0; i < 3; ++i) {
    printf("%c ", vec[p[i]]);
  }
  printf("%.2lf\n", (ans * 0.65 - 1) * 2);
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值