差分约束

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

【方法】

前几天刚看了差分约束,借这个题巩固一下,差分约束就是利用多个条件最后转化成最短路、最长路或者判环问题。

这个是跑最短路,也巩固了一下最少用的spfa算法。

#include <iostream>
#include <cmath>
#include <queue>
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
    int v,w;
}now,next;
vector<node>q[1111];
int dist[1111],vis[1111],num[1111];
int n;
void spfa(int s,int t)
{
    queue<int>p;
    while(!p.empty())
        p.pop();
    for(int i=0;i<=n;i++)
    {
        dist[i]=inf;
        vis[i]=0;
        num[i]=0;
    }
    dist[s]=0;
    vis[s]=num[s]=1;
    p.push(s);
    while(!p.empty())
    {
        int u=p.front();
        p.pop();
        vis[u]=0;
        int len=q[u].size();
        for(int i=0;i<len;i++)
        {
            now=q[u][i];
            int v=now.v;
            int w=now.w;
            if(dist[v]>dist[u]+w)
            {
                dist[v]=dist[u]+w;
                if(!vis[v])
                {
                    vis[v]=1;
                    p.push(v);
                    num[v]++;
                    if(num[v]>n)
                    {
                        cout<<"-1"<<endl;
                        return;
                    }
                }
            }
        }
    }
    if(dist[t]==inf)
        cout<<"-2"<<endl;
    else
        cout<<dist[t]<<endl;
}
int main()
{
    int ml,md;
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    while(cin>>n>>ml>>md)
    {
       int u,v,w;
       for(int i=0;i<ml;i++)
       {
           cin>>u>>v>>w;
           now.v=v;
           now.w=w;
           q[u].push_back(now);
       }
       for(int i=0;i<md;i++)
       {
           cin>>u>>v>>w;
           now.v=u;
           now.w=-w;
           q[v].push_back(now);
       }
       for(int i=1;i<n;i++)
       {
           now.v=i;
           now.w=0;
           q[i+1].push_back(now);
       }
       spfa(1,n);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值