费马大定理+勾股数奇偶规律

people in USSS love math very much, and there is a famous math problem . 

give you two integers nn,aa,you are required to find 22 integers bb,cc such that anan+bn=cnbn=cn.

Input

one line contains one integer TT;(1≤T≤1000000)(1≤T≤1000000) 

next TT lines contains two integers nn,aa;(0≤n≤1000(0≤n≤1000,000000,000,3≤a≤40000)000,3≤a≤40000) 

Output

print two integers bb,cc if bb,cc exits;(1≤b,c≤1000(1≤b,c≤1000,000000,000)000); 

else print two integers -1 -1 instead.

Sample Input

1
2 3

Sample Output

4 5

思路:
费马大定理:当整数n>2或者n==0时,关于的方程 a^n + b^n= c^n没有正整数解。

当n==1时,取值不唯一,在这里我令b=a,c=a*2;

因此我们只讨论n<=2的情况(n=0,n=1,n=2)

当n=2时,满足勾股定理

当a为奇数时:

a=2*k+1;

b=2*k*k+2*k; 

c=2*k*k+2*k+1;

当a为偶数时:

a=2*k;

b=k*k-1;

c=k*k+1;

#include<cstdio>
using namespace std;
typedef long long ll;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll a,n;
        scanf("%lld%lld",&n,&a);
        if(n>2||n==0)
        {
            printf("-1 -1\n");
        }
        if(n==1)
        {
             printf("%lld %lld",a,2*a);
        }
        if(n==2)
        {
            if(a%2)
            {
                ll k=(a-1)/2;
                ll b=2*k*k+2*k;
                ll c=2*k*k+2*k+1;
                printf("%lld %lld\n",b,c);
            }
            else
            {
                ll k=a/2;
                ll b=k*k-1;
                ll c=k*k+1;
                printf("%lld %lld\n",b,c);
            }
        }
    }
}

卡超时卡的真操蛋,,

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值