结题报告-2的整数次幂的种类

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

【题意】

求一个数由多少种2的整数次幂组成的方法

【方法】

看到不少人是用DP做的,我没这么想,找了找规律。

当n=1时,n=1;1种;

当n=2时,n=1+1;

               n=2;2种;

当n=3时,n=1+1+1;

                 n=1+2;2种;

当n=4时,n=1+1+1+1;

                 n=1+2+1;

                 n=2+2;

                 n=4;4种;

当n=5时,n=1+1+1+1+1;

                 n=1+1+1+2;

                 n=1+2+2;

                 n=1+4;4种;

当n=6时,n=1+1+1+1+1+1;

                n=1+1+1+1+2;

                n=1+1+2+2;

                n=2+2+2;

                n=2+4;

                n=1+1+4;6种;

当n=7时,n=1+1+1+1+1+1+1;

                n=1+1+1+1+1+2;

                n=1+1+1+2+2;

                n=1+1+1+4

 

                n=1+2+2+2;

                n=1+2+4; 6种;

当n=8时,n=1+1+1+1+1+1+1+1;

                n=1+1+1+1+1+1+2;

                n=1+1+1+1+2+2;

                n=1+1+2+2+2;

                n=2+2+2+2;

                n=1+1+1+1+4;

                n=1+1+2+4;

                n=2+2+4;

                n=4+4;

               n=8;10种;

           。。。。。。。。

由此可见,当n大于2时,

当n为奇数时,a[n]=a[n-1];

当n为偶数时,a[n]=a[n-1]+a[n/2];

AC代码如下:

#include <iostream>
using namespace std;
const int maxn=1000005;
#define mod 1000000000
int a[maxn];
int main()
{
    ios::sync_with_stdio(false);//处理缓冲区,加快cin效率.
    int i,n;
    a[1]=1;
    a[2]=2;
    for(i=3;i<maxn;i++)

    {
        if(i%2==0)
            a[i]=(a[i-1]+a[i/2])%mod;
        else
        a[i]=a[i-1];
    }
    while(cin>>n)
    {
        cout<<a[n]<<endl;
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值