寒假训练(十一) problem I (最短路径算法)

Time limit 1000 ms
Memory limit 65536 kB
OS Linux
Source Ulm Local 1997

Problem Description:
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

问题链接:https://vjudge.net/contest/279647#problem/I
程序说明:最短路径题,模板为大。(虽然不是很懂最短路径的真正原理。。。。)
AC通过的代码:(大幅度借鉴大佬的代码,小弟甘拜下风。。。)

#include <iostream>
#include <queue>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
struct edge
{
	double x, y;
} d[205];
const double inf = 1e9*1.0;
double fd(edge a, edge b)
{
	return sqrt((a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y));
}
double map[202][202];
int main()
{
	int n;
	int tot = 1;
	bool used[205];
	double cost[202];
	while (cin >> n)
	{
		memset(used, false, sizeof(used));
		if (n == 0)
			break;
		for (int i = 1; i <= n; i++)
			cin >> d[i].x >> d[i].y;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
				map[i][j] = fd(d[i], d[j]);
		}
		used[1] = true;
		double ans = -inf;
		for (int i = 1; i <= n; i++)
			cost[i] = map[1][i];
		for (int i = 1; i < n; i++)
		{
			double minc = inf;
			int k = -1;
			for (int j = 1; j <= n; j++)
			{
				if (!used[j] && minc > cost[j])
				{
					minc = cost[j];
					k = j;
				}
			}
			ans = max(ans, minc);
			used[k] = true;
			if (k == 2)
				break;
			for (int j = 1; j <= n; j++)
			{
				if (map[k][j] < cost[j] && !used[j])
				{
					cost[j] = map[k][j];
				}
			}
		}
		cout << "Scenario #" << tot++ << endl;
		printf("Frog Distance = %.3f\n\n", ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值