10020 - Minimal coverage【最小覆盖、贪心问题】

Minimal coverage

Given several segments of line (int the X axis) with coordinates [Li
, Ri
]. You are to choose the minimal
amount of them, such they would completely cover the segment [0, M].
Input
The first line is the number of test cases, followed by a blank line.
Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri”
(|Li
|, |Ri
| ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair
‘0 0’.
Each test case will be separated by a single line.
Output
For each test case, in the first line of output your programm should print the minimal number of line
segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted
by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be
printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without
quotes).
Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
1
-1 0
-5 -3
2 5
0 0
1
-1 0
0 1
0 0
Sample Output
0
1
0 1

简述:

分析:

说明:

AC代码如下:

#include <iostream>
#include <string.h>
#include <string>
#include <algorithm>
#include <stdio.h>
using namespace std;
struct Node
{
	int x, y;
};
Node a[100010];
int b[100010];
bool tmp(Node c, Node d)
{
	return c.x < d.x;
}
int main()
{
	int t;
	cin >> t;
	while (t--) {
		cout << endl;
		int m, i = 0;
		cin >> m;
		//表示不懂。。。
		while (scanf("%d%d", &a[i].x, &a[i].y) == 2 && (a[i].x || a[i].y))
		{
			i++;
		}
		sort(a, a+i, tmp);
		//x左端点
		int x = 0, y = 0, k = 0;
		//左端点小于所求右端点
		while (x < m) {
			//
			y = x;
			for (int j = 0; j < i; j++) {
				//如果区间左端点小于等于左端点 且区间右端点大于等于右端点
				if (a[j].x <= x && a[j].y >= y) {
					//点解尼度系y啊
					y = a[j].y;
					b[k] = j;
				}
			}
			//如果没有更改过
			if (x == y) {
				k = 0;
				break;
			}
			x = y;
			k++;
		}
		cout << k << endl;
		for (int j = 0; j < k; j++)
			cout << a[b[j]].x << " " << a[b[j]].y << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值