Digital Roots HDU - 1013

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24
39
0
Sample Output
6
3

问题链接:https://cn.vjudge.net/problem/HDU-1013

问题简述:
输入数字,让每个位数相加,若得到的数大于9,则重复刚才的步骤,直到小于10输出,输入0结束循环,这个数即为根。

问题分析:
使用余9法可以得到一个数各位数相加,但当余0时根为9,应为直接使用余9不能计算太大的数,所以先创立数组,将各位的数加一次再使用余9就可以了。

AC的C++程序如下:

#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	int a;
	char b[1000];
	while (cin >>b)
	{
		a = 0;
		if (b[0] == '0'&&strlen(b)==1)break;
		for (int i = 0; i < strlen(b); i++)
			a += b[i] - '0';
			a = a % 9;
		if (a == 0)cout << 9 << endl;
		else cout << a << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值