F - 6 HDU - 1789 Doing Homework again

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
Sample Output
0
3
5

问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1789

问题分析:
贪心问题,将给出数据按分数从大到小排序。如果不能完成作业扣分,将最大的分数安排在当天,如果当天被安排就安排到上一天,知道天数被安排满。

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
struct A
{
	int grade;
	int time;
}a[1001];
bool cmd(A a, A b)
{
	return a.grade > b.grade;
}
int x[1001];
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int b;
		cin >> b;
		for (int i = 1; i <= b; i++)
			cin >> a[i].time;
		for (int i = 1; i <= b; i++)
			cin >> a[i].grade;
		memset(x, 0, sizeof(x));
		sort(a + 1, a + b + 1, cmd);
		int sum=0;
		for (int i = 1; i <= b; i++)
		{
			int j;
			for (j = a[i].time; j >= 1; j--)
			{
				if (x[j] == 0)
				{
					x[j] = 1;
					break;
				}
			}
			if (j == 0)
				sum += a[i].grade;

		}
		cout << sum << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值