迷宫路径 bfs

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

题目分析:
使用bfs , 找出最短路径同时把路径输出,在能走的每一步记住上一步是从哪来。

AC代码如下:

#include<iostream>
using namespace std;
int map[6][6];
int vis[6][6] = { 0 };
int t[4][2] = { {0,1},{0,-1},{1,0},{-1,0} };
struct A
{
	int x;
	int y;
	int pro;
};
A nodes[40];
void input(int head)
{
	while (true)
	{		
		if (nodes[head].x == 0&&nodes[head].y==0)
			break;
		input(nodes[head].pro);
		cout << "(" << nodes[head].x << ", " << nodes[head].y << ")" << endl;
		return;
	}
}
void bfs(int x, int y)
{
	int head = 0;
	int tail = 1;
	nodes[0].x = 0;
	nodes[0].y = 0;
	nodes[0].pro = -1;
	A New;
	while(true)
	{
		if (nodes[head].x == 4 && nodes[head].y == 4)
		{
			input (head);
			return;
		}
		for (int i = 0; i < 4; i++)
		{
			New.x = nodes[head].x + t[i][0];
			New.y = nodes[head].y + t[i][1];
			New.pro = head;
			if(New.x >= 0&&New.x <= 4&&New.y >= 0&&New.y <= 4)
				if (!map[New.x][New.y] && !vis[New.x][New.y])
				{
					nodes[tail] = New;
					tail++;
					vis[New.x][New.y] = 1;
				}
		}
		head++;
	}
}
int main()
{
	for (int i = 0; i < 5; i++)
		for (int j = 0; j < 5; j++)
			cin >> map[i][j];
	cout << "(0, 0)" << endl;
	bfs(0, 0);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值