1.20-e

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

定义一个变量如果是大写就1小写就0,注意如果开着大写时按CapsLock就会变成小写。

#include <iostream>
#include<cstring>
using namespace std;
int main()
{
	int n; cin >> n;
	for (int l = 0; l < n; l++)
	{
		char ch[105];
		cin >> ch; int t; t = 0;
		int k = strlen(ch);
		int i, h = 0;///打开大写就是1关闭就是0
		for (i = 0; i < k; i++)
		{
			if (h == 0)
				if (ch[i] <= 90 && ch[i] >= 65)
				{
					if (ch[i + 1] <= 90 && ch[i + 1] >= 65)
					{
						h = 1; t++;
					}
					else
					{
						h = 0; t++;
					}
				}
			if (h == 1)
			{
				if ((ch[i + 2] <= 122 && ch[i + 2] >= 97)&&( ch[i + 1] <= 122 && ch[i + 1] >= 97))
				{
					t++; h = 0;
				}
				if ((ch[i + 2] <= 90 && ch[i + 2] >= 65) && (ch[i + 1] <= 122 && ch[i + 1] >= 97))
				{
					t++;
				}
			}
			t++;
		}
		if (h == 1)t++;
		cout << t;
		cout << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值