HDU 1209 Clock (结构体排序)

Description

There is an analog clock with two hands: an hour hand and a minute hand. The two hands form an angle. The angle is measured as the smallest angle between the two hands. The angle between the two hands has a measure that is greater than or equal to 0 and less than or equal to 180 degrees.

Given a sequence of five distinct times written in the format hh : mm , where hh are two digits representing full hours (00 <= hh <= 23) and mm are two digits representing minutes (00 <= mm <= 59) , you are to write a program that finds the median, that is, the third element of the sorted sequence of times in a nondecreasing order of their associated angles. Ties are broken in such a way that an earlier time precedes a later time.

For example, suppose you are given a sequence (06:05, 07:10, 03:00, 21:00, 12:55) of times. Because the sorted sequence is (12:55, 03:00, 21:00, 06:05, 07:10), you are to report 21:00.

Input

The input consists of T test cases. The number of test cases (T) is given on the first line of the input file. Each test case is given on a single line, which contains a sequence of five distinct times, where times are given in the format hh : mm and are separated by a single space.

Output

Print exactly one line for each test case. The line is to contain the median in the format hh : mm of the times given. The following shows sample input and output for three test cases.

Sample Input

3
00:00 01:00 02:00 03:00 04:00
06:05 07:10 03:00 21:00 12:55
11:05 12:05 13:05 14:05 15:05

Sample Output

02:00
21:00
用结构体储存每一个时间,以及时间的角度进行结构体排序
对于一个时间 a:b
时针的角度受a和b共同影响
分针角度只受b影响

代码

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<math.h>
#include<stack>
#include<stdio.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
    int a,b;
    int t;//时间
    double v;//角度
};
bool cmp(node a,node b)
{
    if(a.v==b.v)
    return a.t<b.t;
    return a.v<b.v;
}
int main()
{
    //freopen("text.txt","r",stdin);
    int t,a,b;
    node w[5];
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0; i<5; ++i)
        {
            scanf("%d:%d",&a,&b);
            w[i].a=a,w[i].b=b;
            w[i].t=a*60+b;
            a%=12;
            double l=30*a+0.5*b;
            double r=6*b;
            double x=fabs(l-r);
            if(x>180)
                x=360-x;
            w[i].v=x;
        }
        sort(w,w+5,cmp);
        printf("%02d:%02d\n",w[2].a,w[2].b);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值