第一周训练A题

Text Reverse

Time limit1000 msMemory limit65536 kBSourceCodeforces Beta Round #4 (Div. 2 Only)Tagsbrute force math *1200EditorialAnnouncement Tutorial #1 Tutorial #2 Tutorial #3

A-problem A
One hot summer day Pete and his friend Billy decided to buy a watermelon. They chose the biggest and the ripest one, in their opinion. After that the watermelon was weighed, and the scales showed w kilos. They rushed home, dying of thirst, and decided to divide the berry, however they faced a hard problem.

Pete and Billy are great fans of even numbers, that’s why they want to divide the watermelon in such a way that each of the two parts weighs even number of kilos, at the same time it is not obligatory that the parts are equal. The boys are extremely tired and want to start their meal as soon as possible, that’s why you should help them and find out, if they can divide the watermelon in the way they want. For sure, each of them should get a part of positive weight.

Input
The first (and the only) input line contains integer number w (1 ≤ w ≤ 100) — the weight of the watermelon bought by the boys.

Output
Print YES, if the boys can divide the watermelon into two parts, each of them weighing even number of kilos; and NO in the opposite case.

Sample Input
8

Sample Output
YES

问题链接:https://vjudge.net/contest/274223#problem

问题简述:将一个重为1至100的西瓜分为两块,且被分的两块都为偶数。

问题分析:将一个整数分为两份。一份为奇数和2,这份输出NO;另一份为剩下的偶数,输出YES。

程序说明:先限制范围,再用%符号来分奇偶,最后多重if来判断输出。

AC通过的C语言程序如下:

#include <iostream>
using namespace std;
int main()
{
	int w;
	cin >> w;
	if (w >= 1 && w <= 100) {
		if (w % 2 == 0 && w != 2)
			cout << "YES";
		else cout << "NO";

	}
	else cout << "NO";
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值