PAT (Advanced Level) 1035 Password (20分)JAVA实现

在这里插入图片描述

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int total = Integer.valueOf(sc.nextLine());
		int count = 0;
		StringBuilder out = new StringBuilder();
		// 输入
		for (int i = 0; i < total; i++) {
			String line = sc.nextLine();
			String[] arr = line.split(" ");
			String name = arr[0];
			String pwd = arr[1];

			// 判断是否修改
			boolean modified = false;
			if (pwd.indexOf("1") != -1 || pwd.indexOf("0") != -1 || pwd.indexOf("l") != -1 || pwd.indexOf("O") != -1) {
				count++;
				modified = true;
			}

			// 修改
			pwd = pwd.replaceAll("1", "@").replaceAll("0", "%").replaceAll("l", "L").replaceAll("O", "o");
			if (modified) {
				out.append(name + " " + pwd + "\n");
			}
		}

		// 输出
		if (count == 0) {
			if (total == 1) {
				System.out.println("There is 1 account and no account is modified");
			} else {
				System.out.println("There are " + total + " accounts and no account is modified");
			}
		} else {
			System.out.println(count);
			out = out.deleteCharAt(out.length() - 1);
			System.out.println(out.toString());
		}
	}
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值