一、例题
例题:将一副卡牌随机摆成一排,已知只有数字(1-9)和字母(a-z)两类卡牌。对给定长度为N的卡牌序列串S(N<=100),学姐想按如下规则得到数字卡牌序列串D:
(1)每次只能从S的头部或者尾部取一张数字卡牌添加到D末尾;
(2)S中的字母卡牌不能添加到D末尾,直接将它从S拿掉即可;
(3)要求最后拼凑出来的数字卡牌序列串D的数值最大
Input
输入为一行字符串,表示初始的卡牌序列串S
Output
输出数字串D的最大值。如果都是字母牌,输出0。
Sample Input
1a2bb3c4d5e
Sample Output
54321
二、实现代码
代码如下(示例):
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
char input[105];
char temp[105]= {0};
char output[105]= {0};
scanf("%s",input);
int k=0,x=0;
for(int i=0; i<strlen(input); i++)
{
if(isdigit(input[i]))
temp[k++]=input[i];
}
int len=strlen(temp);
if(len==0)
{
printf("0");
return 0;
}
int start=0,end=len-1;
while(start<=end)
{
bool bleft=true;
for(int dx=0; start+dx<=end-dx; dx++)
{
if(temp[start+dx]<temp[end-dx])
{
bleft=false;
break;
}
else if(temp[start+dx]>temp[end-dx])
{
bleft=true;
break;
}
}
if(bleft)
{
output[x++]=temp[start++];
}
else
{
output[x++]=temp[end--];
}
}
puts(output);
return 0;
}