02-线性结构4 Pop Sequence(图解)

题目描述
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

题目大意就是:给定一个栈,它的最大容量是M.按照1,2,3,4…N的顺序入栈,然后任意顺序出栈。我们需要完成的就是判断哪些是可能的输出数列,又哪些不可能输出。

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

每个输入文件包含一个测试用例。对于每种情况,第一行包含3个数字(所有不超过1000): M(堆栈的最大容量),N(推送序列的长度),和K(要检查的弹出序列的数量)。K行跟随,每行包含一个pop序列N个数字。一行中的所有数字都用空格分隔。

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

对于每个输出序列,如果被认为是堆栈的可能输出序列,则在一行中打印“是”,否则打印为“否”

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO

解题思路·: 首先,我们要读懂这个题,“给定一个栈,它的最大容量是M.按照1,2,3,4…N的顺序入栈,然后任意顺序出栈”,从这知道入栈是按照,2,3,4…N的顺序,那么任意顺序出栈,为了能够造成不同的输出序列,怎么入栈和出栈才能够呢?肯定不仅仅是简单一次性全部入栈和一次性全部出栈。那么很可能就是每入栈一个元素或多个元素就会出栈一个或多个元素。因此,我们就找到思路判断哪些可能,哪些不可能了。
图解
在这里插入图片描述
在这里插入图片描述
代码如下(文章末尾附带测试要点)

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define Maxsize 1000//最大容量
typedef struct Node{
	int Top;//栈顶
	int Data[Maxsize];//元素
	int Capacity;//容量
}*Stack;

int IsPopPossible(int Arry[],int M,int N);//判断是否可能为出栈序列 
int main()
{
	int M = 0,N = 0,K = 0,i = 0,j = 0;
	scanf("%d %d %d",&M,&N,&K);//条件读入 
	int Arry[N];//数据存储 
	for(i = 0;i <= K-1;i++){
		for(j = 0;j <= N-1;j++)//每一行数据读入 
			scanf("%d",&Arry[j]);
		if(IsPopPossible(Arry,M,N))//非零时表示可能存在 
			printf("YES\n");
		else 
			printf("NO\n");
	}
	return 0;
}
int IsPopPossible(int Arry[],int M,int N)
{
	int i = 0,flag = 0,count = 0;
	Stack Pile = (Stack)malloc(sizeof(struct Node));//申请并初始化一个空栈 
	Pile->Capacity = M;
	Pile->Top = -1;
	for(i = 1;i <= N;i++){
		if(Pile->Capacity == Pile->Top+1)//栈满 
			return 0;
		else
			Pile->Data[++Pile->Top] = i;//入栈 
		while(Pile->Data[Pile->Top] == Arry[count]){//比较栈顶是否与某数相等 
			Pile->Top--;//出栈 
			count++;//数组往后移位 
		}
	}
	if(count == N)//全部找到并且输出时 
		return 1;
	else 
		return 0; 
}

测试要点
在这里插入图片描述

  • 27
    点赞
  • 22
    收藏
    觉得还不错? 一键收藏
  • 13
    评论
评论 13
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值