Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int m[100010];
int main()
{
int i,n,sum=0,T,g=-1000,k=1,first,last,h=0,j;
cin >> T;
for(j=1;j<=T;j++)
{
h++;
k=1;
sum=0;
g=-1000;
scanf("%d",&n);
for(i=0; i<n; i++)
{
scanf("%d",&m[i]);
sum=sum+m[i];
if(sum>g)
{
g=sum;
first=k;
last=i+1;
}
if(sum<0)
{
sum=0;
k=i+2;
}
}
printf("Case %d:\n",h);
printf("%d %d %d\n",g,first,last);
if(j!=T)
{
printf("\n");
}
}
return 0;
}
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int m[100010];
int main()
{
int i,n,sum=0,T,g=-1000,k=1,first,last,h=0;
cin >> T;
while(T--)
{
h++;
k=1;
sum=0;
g=-1000;
scanf("%d",&n);
for(i=0; i<n; i++)
{
scanf("%d",&m[i]);
sum=sum+m[i];
if(sum>g)
{
g=sum;
first=k;
last=i+1;
}
if(sum<0)
{
sum=0;
k=i+2;
}
}
printf("Case %d:\n",h);
printf("%d %d %d\n",g,first,last);
if(T>0)
{
printf("\n");
}
}
return 0;
}