SDUT 3344 数据结构实验之二叉树五:层序遍历

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Sample Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

abcdefg
xnuli

输出层序遍历最好用的是bfs

#include <iostream>
#include <bits/stdc++.h>
#include <queue>
using namespace std;

int t;

struct node
{
    char data;
    node *ltree;
    node *rtree;
};
node *creat(char s[],node *root)
{
    root=new node;
    root->data=s[t++];
    if(root->data==',')
    {
        return NULL;
    }
    else
    {
        root->ltree=creat(s,root->ltree);
        root->rtree=creat(s,root->rtree);
    }
    return root;
}

void cengxu(node *root)
{
    node *h;
    queue<node *>q;
    q.push(root);
    while(!q.empty())
    {
        h=q.front();
        q.pop();
        if(h)
        {
            cout << h->data;
            q.push(h->ltree);
            q.push(h->rtree);
        }
    }
}

int main()
{
   int a;
   char s[55];
   cin >> a;
   while(a--)
   {
       t=0;
       cin >> s;
       node *root;
       root=creat(s,root);
       cengxu(root);
       cout << endl;
   }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值