Catch That Cow POJ - 3278(bfs)

传送门

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 135778 Accepted: 41998

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

题意:有一个农夫,找他的牛,都在x轴上,给你农夫在x轴上的位置和牛在x轴上的位置,农夫有三种走法,1、现在的步数+1   2、现在的步数 - 1       3、现在的步数 * 2        ,问农夫最短几分钟能到达牛的位置

搜索,对这三个走法进行一个bfs,当到吗位置时候输出就ok了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 5;
int flag[maxn];
struct node{
    int x , step;
}q[maxn];

int bfs(int n , int k){
    node now , next;
    int head = 0 ;
    int tail = 1 ;
    q[head].x = n;
    q[head].step = 0 ;
    flag[n] = 1;
    while(head < tail){
        now = q[head++];
        for(int i = 0 ; i < 3 ; i ++){
            if(i == 0)
                next.x = now.x + 1;
            else if(i == 1)
                next.x = now.x - 1;
            else
                next.x = now.x * 2;
            if(next.x < 0 || next.x > maxn)
                continue;
            if(!flag[next.x]){
                flag[next.x] = 1;
                next.step = now.step + 1;
                q[tail++] = next;
            }
            if(next.x == k)
                return next.step;
        }
    }
}

int main()
{
    int x ,  y;
    while(~scanf("%d%d",&x,&y)){
        memset(flag,0,sizeof(flag));
        if(x >= y)
            cout << x - y << endl;
        else
            cout << bfs(x,y) << endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值