L - Tickets (dp)

本文介绍了一种优化算法,用于解决电影票售卖问题。通过允许相邻顾客一起购票,该算法帮助售票员Joe尽可能早地完成工作。输入包含若干场景,每场景给出顾客单独购票和相邻顾客共同购票所需的时间,输出则是最早下班时间。
摘要由CSDN通过智能技术生成

L - Tickets

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
using namespace std;

int main()
{
    int a,i,b,x,y,z;
    int n[2010],m[2010],dp[2010];
    cin >> a;
    while(a--)
    {
        memset(n,0,sizeof(n));
        memset(m,0,sizeof(m));
        memset(dp,0,sizeof(dp));
        cin >> b;
        for(i=1; i<=b; i++)
        {
            cin >> n[i];
        }
        for(i=2; i<=b; i++)
        {
            cin >> m[i];
        }
        dp[1]=n[1];
        for(i=2; i<=b; i++)
        {
            dp[i]=min(dp[i-1]+n[i],dp[i-2]+m[i]);//一个一个加和连续的两个比较哪个小
        }
        x=dp[b]/3600+8;
        y=dp[b]/60%60;
        z=dp[b]%60;
        printf("%02d:%02d:%02d am\n",x,y,z);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值